Melding "Keyboard not detected"

Status
Niet open voor verdere reacties.

Mik

Medewerker
Forumleiding
Qtex;n235605 zei:
mogelijk dien jij de usb controllers aan te zetten in het bios...wellicht de upgrade naar 1809 al binnen gekregen indien zo kan het hier aan liggen ….kan het anders niet verklaren .
Is nog 1803. Denk dat ik nog een USB pci kaartje liggen heb. Zie eens in mijn brol of ik het terugvind.
Heb een USB pci kaartje gevonden, maar hiervoor heb ik geen plaats. Ik heb enkel 1 PCIEX16 en 2 PCIEX1-1 slotjes.
Ik heb een externe USB 3.0 hub met voeding. Daar het bordje voorlopig aangehangen en dit werkt. Nadeel, hub blijft altijd onder spanning staan.
 
Laatst bewerkt:

Mik

Medewerker
Forumleiding
Voorlopig met externe hub werkt het nog. Zou dit te duiden op slechte contacten op het MB? Zou me verwonderen want een slecht contact heb je en zou moeten blijven. Maar niet telkens terug in orde zijn als de verbinding opnieuw gemaakt wordt.
 

Skippy

Beheerder
Forumleiding
Admin
Kan ook de chip op het moederbord die dit verkeer regelt zijn die niet goed meer werkt.
 

Mik

Medewerker
Forumleiding
Gekeken op internet. Vind niet zo gauw een kaartje dat van PCIEX 1-1 naar USB gaat. Iemand een link?
 

Qtex

Beheerder
Forumleiding
Admin
bedoel je zo iets als dit … klik
nadeel is dat de usb aansluitingen in je kast komen te zitten !
Ashampoo_Snap_donderdag 25 oktober 2018_11h56m00s_001_.png
 

Mik

Medewerker
Forumleiding
Qtex;n235637 zei:
bedoel je zo iets als dit … klik
nadeel is dat de usb aansluitingen in je kast komen te zitten !
Ja, dat is het maar met de aansluitingen binnen. Dit is een foute opstelling.
 

Qtex

Beheerder
Forumleiding
Admin
m.a.w. je heb dezelfde kaart nodig maar met de usb's als insteekpoorten ...
 

Mik

Medewerker
Forumleiding
Qtex;n235640 zei:
m.a.w. je heb dezelfde kaart nodig maar met de usb's als insteekpoorten ...
Met de USB naar buitenkant. Heb er al een paar gevonden maar vind ze nogal prijzig. 30€ ????????
 

Mik

Medewerker
Forumleiding
Vind die te prijzig voor hetgeen het moet dienen.
Ik heb nu een I7 MB. Daarin 16GB geheugen en een SSD van 500GB. Ook nog een interne schijf van 2TB. Zou dan nog liever een opleg doen en een nieuw moederbord kopen. Huidig MB is een Asus B85M-G
 

Mik

Medewerker
Forumleiding
Ik blijf het vreemd vinden. Ik heb zoals beschreven mijn toetsenbord aangesloten op een externe hub met voeding. Als de voeding niet opstaat van de hub krijg ik in bios de melding "Keyboard not detected".
Als ik dan gedurende de opstart de voeding opzet van de hub, zie ik direct reactie van het toetsenbord en werkt het wel perfect. Dus het bord dat niet werkt gedurende de bios opstart, werkt wel als het erna opgezet wordt. Zou dit dan toch een Windows probleem kunnen zijn. Het vreemde is dat ik vroeger nooit die melding kreeg en dat ik niets aangepast heb in bios. Enkel nu na opnieuw problemen heb ik de ps2 uitgezet daar ik met USB werk. Mijn muis zit uiteraard ook op USB en die blijft het perfect doen.
 

DDragon80

Beheerder
Forumleiding
Admin
Als je melding via de BIOS krijgt, kan dit nooit een Windows probleem zijn. Uiteraard draagt Windows hier de gevolgen van, direct of indirect. Maar je BIOS staat los van het OS.
Kan zijn dat die niet voldoende stroom kan leveren aan de nodige apparaten. Het kan best zijn dat die muis ook niet 100% werkt. Maar de BIOS gaat eerder melding maken van een "ontbrekend" keyboard ipv een ontbrekende muis. Een muis is optioneel voor een BIOS/Computer. Een keyboard is minimaal vereist, daarom die melding. Vroeger kon je die detectie zelfs uitzetten, en ik vermoed nog steeds. Voor HMI devices die enkel met touchscreen werken bijvoorbeeld.
 

Mik

Medewerker
Forumleiding
DDragon80;n235660 zei:
Als je melding via de BIOS krijgt, kan dit nooit een Windows probleem zijn. Uiteraard draagt Windows hier de gevolgen van, direct of indirect. Maar je BIOS staat los van het OS.
Kan zijn dat die niet voldoende stroom kan leveren aan de nodige apparaten. Het kan best zijn dat die muis ook niet 100% werkt. Maar de BIOS gaat eerder melding maken van een "ontbrekend" keyboard ipv een ontbrekende muis. Een muis is optioneel voor een BIOS/Computer. Een keyboard is minimaal vereist, daarom die melding. Vroeger kon je die detectie zelfs uitzetten, en ik vermoed nog steeds. Voor HMI devices die enkel met touchscreen werken bijvoorbeeld.
Ja, klopt, maar waarom gaat het toetsenbord dan aan als ik stroom geef op de hub. Die gaat dan toch aan via Windows. Die hub krijgt toch ook via een usb de detectie van een keyboard. Waarom niet als de hub er niet tussen zit? Als ik zonder die hub ertussen wil opstarten, moet ik mij aanmelden op de computer. Dit doe ik dan via het schermtoetsenbord. Geen probleem met aanloggen. Je zou dan toch moeten denken dat Windows het bordje wél moet zien. Of zou het te maken kunnen hebben met de voeding? In bios zie ik dat de spanning juist is. Voeding is een Corsair CX430 dus 430W. Volgens mij aan de lage kant.
 

DDragon80

Beheerder
Forumleiding
Admin
Je geeft het antwoord al deels zelf. Als die onboard USB IC niet voldoende stroom kan leveren aan de gekoppelde apparaten, dan vindt er geen detectie plaats. Maar als een verder gekoppeld apparaat die stroom wel kan leveren via externe voeding, kan de detectie wel plaatsvinden. De nodige signalen (voltages) zullen wel correct zijn, maar de stroom naar de apparaten zal het probleem zijn.

Maw, de hub levert de stroom naar de apparaten, niet(meer) de onboard USB IC. Die laatste heeft daar mogelijk een probleem mee (dmv een defect). Dus de hub levert de stroom, waardoor de signalen op de correcte voltages blijven en het apparaat correct werkt.
 
  • Like
Waarderingen: Mik

Skippy

Beheerder
Forumleiding
Admin
DDragon80;n235662 zei:
Je geeft het antwoord al deels zelf. Als die onboard USB IC niet voldoende stroom kan leveren aan de gekoppelde apparaten, dan vindt er geen detectie plaats. Maar als een verder gekoppeld apparaat die stroom wel kan leveren via externe voeding, kan de detectie wel plaatsvinden. De nodige signalen (voltages) zullen wel correct zijn, maar de stroom naar de apparaten zal het probleem zijn.

Maw, de hub levert de stroom naar de apparaten, niet(meer) de onboard USB IC. Die laatste heeft daar mogelijk een probleem mee (dmv een defect). Dus de hub levert de stroom, waardoor de signalen op de correcte voltages blijven en het apparaat correct werkt.
Was ook mijn conclusie, zie #33 https://www.pctuts.be/forum/multimedia-hardware-software/hardware/234980-melding-keyboard-not-detected?p=235633#post235633
 
  • Like
Waarderingen: Mik
Status
Niet open voor verdere reacties.
Bovenaan Onderaan